Главная / Интернет-технологии /
Администрирование почтовых серверов sendmail / Тест 13
Администрирование почтовых серверов sendmail - тест 13
Упражнение 1:
Номер 1
Аббревиатура провайдеров сети Internet:
Ответ:
 (1) ISP 
 (2) IPR 
 (3) IRS 
 (4) ISO 
Номер 2
Перед установкой и конфигурированием почтового сервера следует обсудить с провайдером Internet следующие основные вопросы:
Ответ:
 (1) хостинг доменных имен 
 (2) метод доставки почты 
 (3) параметры соединения 
Номер 3
В недалеком прошлом регистрацией доменных имен занимался:
Ответ:
 (1) ICPN 
 (2) NIC 
 (3) NPC 
 (4) NCP 
Упражнение 2:
Номер 1
Единственное требование для поддержки домена в системе DNS:
Ответ:
 (1) наличие не менее одного DNS-сервера 
 (2) наличие не менее трех DNS-серверов 
 (3) наличие не менее двух DNS-серверов 
 (4) наличие не менее четырех DNS-серверов 
Номер 2
На почтовом сервере необходимо запустить программу, реализующую функции сервера SMTP, например:
Ответ:
 (1) sendmail 
 (2) smail 
 (3) smtpd 
 (4) popd 
Номер 3
Методами доставки почты являются:
Ответ:
 (1) получение почты для домена через один почтовый ящик на сервере провайдера 
 (2) накопление почты для домена у провайдера 
 (3) прямая доставка почты 
Упражнение 3:
Номер 1
В основу третьего способа получения почты для локального домена положен:
Ответ:
 (1) виртуальный почтовый хостинг 
 (2) логический почтовый хостинг 
 (3) выделенный почтовый хостинг 
 (4) общий почтовый хостинг 
Номер 2
Способами соединения почтового сервера под управлением ОС Linux с провайдером Internet являются:
Ответ:
 (1) выделенное РРР-соединение 
 (2) коммутируемое РРР-соединение 
 (3) коммутируемое UUCP-соединение 
 (4) коммутируемое UDP-соединение 
Номер 3
В настоящее время выделенное соединение почтового сервера с сетью Internet организуется:
Ответ:
 (1) одним способом 
 (2) двумя способами 
 (3) тремя способами 
 (4) четырмя способами 
Упражнение 4:
Номер 1
Для установления РРР-соединения по запросу от почтового сервера в ОС Linux используется программа:
Ответ:
 (1) edl 
 (2) xdial 
 (3) diald 
 (4) dialup 
Номер 2
Главным преимуществом при работе с UUCP является:
Ответ:
 (1) высокий уровень безопасности 
 (2) средний уровень безопасности 
 (3) низкий уровень безопасности 
Номер 3
Типовыми схемами подключения почтового сервера к сети Internet являются:
Ответ:
 (1) коммутируемое UUCP-соединение с использованием почтовой очереди на сервере провайдера 
 (2) выделенное РРР-соединение с непосредственной доставкой почты из Internet 
 (3) коммутируемое РРР-соединение с использованием одного почтового ящика на почтовом сервере провайдера 
 (4) коммутируемое РРР-соединение с использованием почтовой очереди на сервере провайдера 
Упражнение 5:
Номер 1
Для установки РРР-соединения с узлом провайдера Internet применяется программа pppd, для работы которой необходим сценарий:
Ответ:
 (1) path 
 (2) sender 
 (3) chat 
 (4) upper 
Номер 2
После создания сценария chat вы можете запустить программу pppd для подключения локального почтового сервера к серверу провайдера:
Ответ:
 (1) pppd ttyS1 38400 connect '/usr/sbin/chat -v -f /root/isp.chat' modem crtscts defaultroute 
 (2) pppd ttyS1 38400 connect '/usr/sbin/chat -v -f /root/isp.chat' 
 (3) pppd ttyS1 38400 /root/isp.chat' modem crtscts defaultroute 
 (4) pppd ttyS1 38400 connect 
Номер 3
Для того чтобы почтовый сервер на базе ОС Linux правильно преобразовывал доменные имена, необходимо в качестве переменной nameserver указать имя сервера DNS провайдера Internet в:
Ответ:
 (1) /home/resolv.conf 
 (2) /var/resolv.conf 
 (3) /etc/resolv.conf 
 (4) /opt/resolv.conf 
Упражнение 6:
Номер 1
При создании нового файла конфигурации для sendmail можно воспользоваться макропроцессором m4:
Ответ:
 (1) direct.m4 > sendmail.cf 
 (2) m4 > sendmail.cf 
 (3) m4 < sendmail.cf 
 (4) m4 direct.m4 > sendmail.cf 
Номер 2
Для создания новой базы данных из текстового файла надо воспользоваться утилитой makemap:
Ответ:
 (1) makemap hash /etc/mail/access.db
> /etc/mail/access 
 (2) makemap hash /etc/mail/access.db
< /etc/mail/access 
 (3) makemap hash /etc/mail/access.db
= /etc/mail/access 
 (4) makemap hash /etc/mail/access.db
+ /etc/mail/access 
Номер 3
В команде на запуск программы sendmail следует указать параметр -q, например, следующим образом:
Ответ:
 (1) /usr/sbin/sendmail -bd
-q30m 
 (2) /usr/sbin/sendmail -bd
-qmq 
 (3) /usr/sbin -bd
-q 
 (4) /usr/sbin -bd
-q30m 
Упражнение 7:
Номер 1
Если в имеющейся у вас версии ОС Linux отсутствует бинарный файл программы diald, то его можно получить через Internet по адресу:
Ответ:
 (1) http://diald.ch 
 (2) http://diald.unix.ch 
 (3) http://www.unix.org 
 (4) http://www.diald.net 
Номер 2
Запустить программу GNU make с параметром depend можно так:
Ответ:
 (1) cd depend make 
 (2) mk install depend 
 (3) make depend 
 (4) mk depend 
Номер 3
Запустить программу GNU make без параметров для компиляции можно так:
Ответ:
 (1) make 
 (2) maked 
 (3) makefile 
 (4) mk 
Упражнение 8:
Номер 1
В какой строке описывается порт на Linux-сервере, к которому подключен модем:
Ответ:
 (1) speed 115200 
 (2) device /dev/ttyS1 
 (3) connect-timeout 180 
 (4) defaultroute 
Номер 2
В какой строке определяется стандартный фильтр diald, который устанавливает правила и время установки и завершения РРР-соединения:
Ответ:
 (1) see /usr/lib/diald for sample config files 
 (2) remote 192.168.1.2 
 (3) fifo /etc/diald/diald.ctl 
 (4) include /usr/lib/diald/standard.filter 
Номер 3
Запустить diald может только пользователь с правами:
Ответ:
 (1) root 
 (2) user 
 (3) group 
 (4) other 
Упражнение 9:
Номер 1
Получив сообщения от почтового сервера провайдера, программа fetchmail должна проанализировать заголовки формата:
Ответ:
 (1) RFC1522 
 (2) RFC1022 
 (3) RFC922 
 (4) RFC822 
Номер 2
Каждый пользователь, которому разрешено принимать почту из Internet, должен быть описан в файле:
Ответ:
 (1) .fetml.rc пользователя root 
 (2) .fetch.rc пользователя root 
 (3) .fetchmail.rc пользователя root 
 (4) .fetchmail пользователя root 
Номер 3
В какой строке определяется почтовый сервер провайдера, к которому для получения почты подключается программа fetchmail:
Ответ:
 (1) poll mail.isp.net with proto POP3 
 (2) localdomains smallorg.org 
 (3) user "rich" with password "guitar" is 
Упражнение 10:
Номер 1
Запуск fetchmail через определенные интервалы времени можно обеспечить с помощью утилиты ОС Linux:
Ответ:
 (1) diald 
 (2) cron 
 (3) qpopper 
 (4) kppp 
Номер 2
Для организации коммутируемых соединений по протоколу РРР необходимо:
Ответ:
 (1) установить программу diald 
 (2) установить программу pppd 
 (3) настроить файл diald.conf 
Номер 3
Для увеличения интервала ожидания можно отредактировать следующий файл, который прилагается к программе diald:
Ответ:
 (1) /etc/lib/diald/standard.filter 
 (2) /opt/lib/diald/standard.filter 
 (3) /var/lib/diald/standard.filter 
 (4) /usr/lib/diald/standard.filter 
Упражнение 11:
Номер 1
В какой строке файла .fetchmailrc указано альтернативное имя домена, на который почтовый сервер под управлением ОС Linux будет принимать почту:
Ответ:
 (1) poll mail.isp.net with proto ETRN 
 (2) localdomains smallorg.org 
 (3) no dns 
 (4) no envelope 
Номер 2
Стандартным пакетом для работы с UUCP на платформе Linux является программный пакет:
Ответ:
 (1) Alter UUCP 
 (2) Lock UUCP 
 (3) Taylor UUCP 
 (4) Ritchi UUCP 
Номер 3
Если же в имеющейся у вас версии Linux отсутствуют программные пакеты для работы с UUCP, можно получить исходный код таких программ на сервере sunsite.unc.edu в каталоге:
Ответ:
 (1) /pub/systems/network/uucp 
 (2) /pub/linux/network/uucp 
 (3) /pub/network/uucp 
 (4) /pub/linux/systems/network/uucp 
Упражнение 12:
Номер 1
Какой файл конфигурации Taylor UUCP определяет имя узла для локального почтового сервера на базе ОС Linux:
Ответ:
 (1) sys 
 (2) config 
 (3) port 
 (4) dial 
Номер 2
После создания файлов конфигурации для Taylor UUCP необходимо установить UUCP-соединение с сервером UUCP провайдера, для чего надо воспользоваться командой:
Ответ:
 (1) /var/sbin -s ispmail 
 (2) /home/sbin/uucico -s ispmail 
 (3) /opt/uucico -s ispmail 
 (4) /usr/sbin/uucico -s ispmail 
Номер 3
Для задания сценариев, выполняемых утилитой cron, надо использовать программу:
Ответ:
 (1) crontab 
 (2) cront 
 (3) cronab 
 (4) cronb